This project is read-only.
6

Resolved

ExtendedMerge2012 installation failure

description

Getting the following from the installer:

10/10/2013 8:55:14 AM - Microsoft VSIX Installer
10/10/2013 8:55:14 AM - -------------------------------------------
10/10/2013 8:55:14 AM - Initializing Install...
10/10/2013 8:55:14 AM - Microsoft.VisualStudio.ExtensionManager.MissingPackagePartException: The package does not contain the software license agreement that is specified in the extension manifest (The MIT License (MIT).txt).
at Microsoft.VisualStudio.ExtensionManager.ExtensionHeaderImpl.get_License()
at VSIXInstaller.App.InitializeInstall()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()

comments

bjornbouetsmith wrote Oct 22, 2013 at 7:12 AM

This is caused by the file "The MIT License (MIT).txt" - not having the flag "Include in Vsix" set - in the properties of the file - so its an easy fix.

If you are eager to get this release - just download the latest changeset - and apply this fix.

jaweier_CodePlex wrote Oct 29, 2013 at 8:50 PM

Can we get this fixed quick... IV tried downloading the source my self and changing that... But for some odd reason the solution will not open

wrote Nov 4, 2013 at 1:50 PM

wrote Nov 6, 2013 at 2:27 PM

wrote Nov 18, 2013 at 6:09 PM

dekel wrote Jan 12, 2014 at 1:29 PM

same form me i have the same error
1/12/2014 3:26:24 PM - Microsoft.VisualStudio.ExtensionManager.MissingPackagePartException: The package does not contain the software license agreement that is specified in the extension manifest (The MIT License (MIT).txt).
at Microsoft.VisualStudio.ExtensionManager.ExtensionHeaderImpl.get_License()
at VSIXInstaller.App.InitializeInstall()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()

and i cant open the solution

Poco wrote Jan 17, 2014 at 10:41 PM

I would really like to try this plugin. How do I load the solution?

What are the environment requirements?

When I download the latest source and try to open the ExtendedMerge solution I get an error that the project is incompatible with the current version of VS (I tried opening it with VS 2010 and VS 2012). VS 2012 converted the project, so I assume that it is a 2010 project, and still would not load.

wrote Feb 26, 2014 at 6:58 PM

relmaster wrote Feb 26, 2014 at 8:07 PM

  • I would really like to try this plugin. How do I load the solution?
    Open visual studio and select the project
  • What are the environment requirements?
    For me: VS 2012 SDK (preferably update 4)
To solve this error, get the source code and remove "The MIT License (MIT)" inside of the manifest, after this you need to build and run the .vsix file

wrote Mar 7, 2014 at 2:59 PM

This version requires .NET 4.5 and VS/TFS 2012


I checked *.txt manifest file and it works fine.

wrote Mar 7, 2014 at 4:53 PM